buildrootschalter/package/libdnet/libdnet-002-python-makefile.patch
Peter Korsgaard 21438ec500 libdnet: fix python module build
Ensure the correct compiler/linker flags are used.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
2011-06-21 00:01:34 +02:00

17 lines
515 B
Diff

---
python/Makefile.am | 1 +
1 file changed, 1 insertion(+)
Index: libdnet-1.11/python/Makefile.am
===================================================================
--- libdnet-1.11.orig/python/Makefile.am
+++ libdnet-1.11/python/Makefile.am
@@ -11,6 +11,7 @@
pyrexc $(srcdir)/dnet.pyx
python-build: $(srcdir)/dnet.c
+ CC="$(CC)" LDSHARED="$(CC) -shared" CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" $(PYTHON) setup.py build_ext -I$(PYINCDIR) -L$(PYLIBDIR)
$(PYTHON) setup.py build
touch python-build