libdnet: fix python module build

Ensure the correct compiler/linker flags are used.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
Peter Korsgaard 2011-06-21 00:01:34 +02:00
parent 377b2785c1
commit 21438ec500
2 changed files with 10 additions and 4 deletions

View File

@ -1,10 +1,16 @@
--- a/python/Makefile.am 2006-01-15 18:08:23.000000000 +1100
+++ b/python/Makefile.am 2008-09-04 15:25:52.000000000 +1000
---
python/Makefile.am | 1 +
1 file changed, 1 insertion(+)
Index: libdnet-1.11/python/Makefile.am
===================================================================
--- libdnet-1.11.orig/python/Makefile.am
+++ libdnet-1.11/python/Makefile.am
@@ -11,6 +11,7 @@
pyrexc $(srcdir)/dnet.pyx
python-build: $(srcdir)/dnet.c
+ CC="$(CC)" LDSHARED="$(CC) -shared" $(PYTHON) setup.py build_ext -I$(PYINCDIR)
+ CC="$(CC)" LDSHARED="$(CC) -shared" CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" $(PYTHON) setup.py build_ext -I$(PYINCDIR) -L$(PYLIBDIR)
$(PYTHON) setup.py build
touch python-build

View File

@ -17,7 +17,7 @@ LIBDNET_CONF_OPT = \
ifneq ($(BR2_PACKAGE_LIBDNET_PYTHON),)
LIBDNET_DEPENDENCIES = python
LIBDNET_CONF_OPT += --with-python
LIBDNET_MAKE_OPT = PYTHON=python$(PYTHON_VERSION_MAJOR) PYINCDIR=$(STAGING_DIR)/usr/include/python$(PYTHON_VERSION_MAJOR)
LIBDNET_MAKE_OPT = PYINCDIR=$(STAGING_DIR)/usr/include/python$(PYTHON_VERSION_MAJOR) PYLIBDIR=$(STAGING_DIR)/usr/lib
LIBDNET_INSTALL_TARGET_OPT = $(LIBDNET_MAKE_OPT) DESTDIR=$(TARGET_DIR) INSTALL_STRIP_FLAG=-s install-exec
LIBDNET_INSTALL_STAGING_OPT = $(LIBDNET_MAKE_OPT) DESTDIR=$(STAGING_DIR) install
endif