buildrootschalter/package/ympd/ympd-0002-only-c-language.patch
Eric Limpens 40aa523af2 ympd: new package
[Thomas:
 - Add the package to package/Config.in
 - Add dependency on largefile
 - Add new patch to CMakeLists.txt to remove the unused C++ dependency
 - Change the existing CMakeLists.txt patch to simply remove the
   problematic code, and reword the explanation.]

Signed-off-by: Eric Limpens <limpens@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2014-10-04 14:39:03 +02:00

22 lines
704 B
Diff

ympd is implemented only in C
By default, CMake assumes that the project is using both C and C++. By
explicitly passing 'C' as argument of the project() macro, we tell
CMake that only C is used, which prevents CMake from checking if a C++
compiler exists.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/CMakeLists.txt
===================================================================
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,6 @@
cmake_minimum_required(VERSION 2.6)
-project (ympd)
+project (ympd C)
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${PROJECT_SOURCE_DIR}/cmake/")
set(CPACK_PACKAGE_VERSION_MAJOR "1")
set(CPACK_PACKAGE_VERSION_MINOR "2")