buildrootschalter/package/python-pycrypto/python-pycrypto-0001-remove-incorrect-header-path.patch
Thomas Petazzoni 0fd8e8ddb4 python-pycrypto: do not include host headers
This commit adds a patch to python-pycrypto that removes /usr/include
for the headers path, which is wrong when cross-compiling.

Fixes:

  http://autobuild.buildroot.org/results/5bf/5bf5e31c485a4ee8c0b0a5721205f0fed9b5ae5d/build-end.log

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2013-12-20 22:23:10 +01:00

22 lines
736 B
Diff

Do not use /usr/include for headers
Using /usr/include is wrong when doing cross-compilation, so get rid
of it, and rely on the compiler to use the appropriate default paths
for headers.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/setup.py
===================================================================
--- a/setup.py
+++ b/setup.py
@@ -370,7 +370,7 @@
'ext_modules': plat_ext + [
# _fastmath (uses GNU mp library)
Extension("Crypto.PublicKey._fastmath",
- include_dirs=['src/','/usr/include/'],
+ include_dirs=['src/'],
libraries=['gmp'],
sources=["src/_fastmath.c"]),