buildrootschalter/package/mysql/mysql-0004-Fix-gen_lex_hash-execution.patch
Marcelo Gutierrez f7aa61c6f9 mysql: add option to build the server
Signed-off-by: Marcelo Gutierrez (UTN/FRH) <kuyurix@gmail.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2014-03-03 23:13:18 +01:00

33 lines
1.0 KiB
Diff

Makefile: fix cross-compiling the server
MySQL Makefile believes it can run code it just compiled, to
generate a header. This does not work for cross-compilation.
Instead, use a pre-installed host-version of the required tool.
Signed-off-by: Marcelo Gutierrez (UTN/FRH) <kuyurix@gmail.com>
--- mysql-5.1.70/sql/Makefile.am
+++ mysql-5.1.70.patch/sql/Makefile.am
@@ -177,7 +177,7 @@
# this avoid the rebuild of the built files in a source dist
lex_hash.h: gen_lex_hash.cc lex.h
$(MAKE) $(AM_MAKEFLAGS) gen_lex_hash$(EXEEXT)
- ./gen_lex_hash$(EXEEXT) > $@-t
+ gen_lex_hash$(EXEEXT) > $@-t
$(MV) $@-t $@
# For testing of udf_example.so
--- mysql-5.1.70/sql/Makefile.in
+++ mysql-5.1.70.patch/sql/Makefile.in
@@ -1310,7 +1310,7 @@
# this avoid the rebuild of the built files in a source dist
lex_hash.h: gen_lex_hash.cc lex.h
$(MAKE) $(AM_MAKEFLAGS) gen_lex_hash$(EXEEXT)
- ./gen_lex_hash$(EXEEXT) > $@-t
+ gen_lex_hash$(EXEEXT) > $@-t
$(MV) $@-t $@
# We might have some stuff not built in this build, but that we want to install