buildrootschalter/package/curlftpfs/curlftpfs-001-free_ftpfs_file-memleak-fix.patch
Richard Braun 72df08ee45 curlftpfs: new package
[Peter: updated with BR changes, Config.in tweaks, dropped configure.ac patch]
Signed-off-by: Richard Braun <rbraun@...>
Signed-off-by: Alexander Varnin <fenixk19@mail.ru>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
2013-01-14 22:31:31 +01:00

15 lines
477 B
Diff

Borrowed from the curlftpfs_0.9.2-5 Debian package.
Fix a memory leak. See Bug #587250.
--- a/ftpfs.c 2008-04-30 01:05:47.000000000 +0200
+++ a/ftpfs.c.slesimple 2010-01-01 22:12:10.000000000 +0100
@@ -615,6 +615,8 @@ static void free_ftpfs_file(struct ftpfs
sem_destroy(&fh->data_need);
sem_destroy(&fh->data_written);
sem_destroy(&fh->ready);
+ if (fh->buf.size) { buf_free(&fh->buf); }
+ if (fh->stream_buf.size) { buf_free(&fh->stream_buf); }
free(fh);
}