buildrootschalter/package/pifmrds/pifmrds-0003-rds_wav-strcmp.patch
Eric Limpens 39ae2a31c2 package/pifmrds: new package
We needs three little patches:
  - one to make the existing Makefile cross-compile friendly
  - one to pass the LDFLAGS at link time
  - one to add a missing include

[Thomas: add missing 'depends on BR2_arm' in comment, renumber patches
to start at 0001 and not 0000.]

Signed-off-by: Eric Limpens <limpens@gmail.com>
[yann.morin.1998@free.fr: add .mk header; cleanup and split the
 Makefile patch, add missing include; add comments to all patches]
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2014-06-29 10:57:15 +02:00

18 lines
646 B
Diff

rds_wav: add missign include for strcmp()
strcmp() is declared in string.h, so include it.
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
diff -durN pifmrds-c67306ea9b8d827f45e0d90279d367e97119bcb1.orig/src/rds_wav.c pifmrds-c67306ea9b8d827f45e0d90279d367e97119bcb1/src/rds_wav.c
--- pifmrds-c67306ea9b8d827f45e0d90279d367e97119bcb1.orig/src/rds_wav.c 2014-05-04 18:21:40.000000000 +0200
+++ pifmrds-c67306ea9b8d827f45e0d90279d367e97119bcb1/src/rds_wav.c 2014-06-21 17:39:22.999128453 +0200
@@ -26,6 +26,7 @@
#include <stdlib.h>
#include <math.h>
#include <sndfile.h>
+#include <string.h>
#include "rds.h"
#include "fm_mpx.h"