buildrootschalter/package/libgtk3/libgtk3-0002-fix-introspection-check.patch
Hadrien Boutteville c4ec97d505 libgtk3: new package
This package provides Gtk+ 3.0, a graphical toolkit.

[Peter: fix Config.in deps, ensure atleast 1 backend, remove redundant info]
Signed-off-by: Hadrien Boutteville <hadrien.boutteville@gmail.com>
Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
[Eric: added backend support, use of pkgconf for host-libgtk3]
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2014-10-15 14:52:23 +02:00

29 lines
1.0 KiB
Diff

Fix HAVE_INTROSPECTION does not appear in AM_CONDITIONAL
During autoreconf GOBJECT_INTROSPECTION_CHECK could not be resolved because we
don't have introspection which provides its custom m4 macro. Reconfigure fails
with:
gdk/Makefile.am:196: error: HAVE_INTROSPECTION does not appear in AM_CONDITIONAL
gtk/Makefile.am:1347: error: HAVE_INTROSPECTION does not appear in AM_CONDITIONAL
We avoid to add a copy of introspection.m4 in the m4 directory of libgtk3 by
adding a check, as performed in Systemd.
Signed-off-by: Hadrien Boutteville <hadrien.boutteville@gmail.com>
--- a/configure.ac
+++ b/configure.ac
@@ -1621,7 +1621,10 @@
# GObject introspection
##################################################
-GOBJECT_INTROSPECTION_CHECK(introspection_required_version)
+m4_ifdef([GOBJECT_INTROSPECTION_CHECK],
+ [GOBJECT_INTROSPECTION_CHECK(introspection_required_version)],
+ [AM_CONDITIONAL([HAVE_INTROSPECTION], [false])
+ enable_introspection=no])
##################################################
# colord module