buildrootschalter/package/x11r7/xdriver_xf86-video-ati/xdriver_xf86-video-ati-6.6.3.patch
Eric Andersen a7e49eb2af Merge in X11R7 patches from Julien Letessier, posted 04 Jul 2007. Doesn't
quite work yet for me, but this clearly is a huge project and not having it
quite work on the first pass is hardly unexpected.  We definately want this
stuff in buildroot.
2007-08-10 19:07:51 +00:00

24 lines
769 B
Diff

--- xf86-video-ati-6.6.3/configure.ac.orig 2007-06-10 12:02:12.000000000 +0200
+++ xf86-video-ati-6.6.3/configure.ac 2007-06-10 12:02:31.000000000 +0200
@@ -84,13 +84,19 @@
# Checks for header files.
AC_HEADER_STDC
-if test "$DRI" != no; then
+if test "x$DRI" != xno; then
+ if test "$cross_compiling" = no; then
AC_CHECK_FILE([${sdkdir}/dri.h],
[have_dri_h="yes"], [have_dri_h="no"])
AC_CHECK_FILE([${sdkdir}/sarea.h],
[have_sarea_h="yes"], [have_sarea_h="no"])
AC_CHECK_FILE([${sdkdir}/dristruct.h],
[have_dristruct_h="yes"], [have_dristruct_h="no"])
+ else
+ have_dri_h="yes"
+ have_sarea_h="yes"
+ have_dristruct_h="yes"
+ fi
fi
AC_MSG_CHECKING([whether to include DRI support])