buildrootschalter/package/qdecoder/qdecoder-0001-fix-make-install.patch
Sagaert Johan 4e94e89709 qdecoder : new package
Features:
   Supports parsing a request encoded by GET/POST method
   Supports parsing multipart/form-data encoding.(in-memory and direct disk)
   Supports COOKIE handling.
   Supports Session management.
   Supports FastCGI

[Peter: drop invalid patch, add patches for make install + configure paths]
Signed-off-by: Sagaert Johan <sagaert.johan@skynet.be>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2014-05-07 22:18:11 +02:00

41 lines
1.4 KiB
Diff

[PATCH] fix make install to respect DESTDIR
And also ensure destination directories exist.
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
src/Makefile.in | 17 +++++++++--------
1 file changed, 9 insertions(+), 8 deletions(-)
Index: qdecoder-r12.0.5/src/Makefile.in
===================================================================
--- qdecoder-r12.0.5.orig/src/Makefile.in
+++ qdecoder-r12.0.5/src/Makefile.in
@@ -78,17 +78,18 @@
${LN_S} -f ${SLIBREALNAME} ${SLIBNAME}
install: all
- ${INSTALL_DATA} qdecoder.h ${HEADERDIR}/qdecoder.h
- ${INSTALL_DATA} ${LIBNAME} ${LIBDIR}/${LIBNAME}
- ${INSTALL_DATA} ${SLIBREALNAME} ${LIBDIR}/${SLIBREALNAME}
- ( cd ${LIBDIR}; ${LN_S} -f ${SLIBREALNAME} ${SLIBNAME} )
+ mkdir -p ${DESTDIR}/${HEADERDIR} ${DESTDIR}/${LIBDIR}
+ ${INSTALL_DATA} qdecoder.h ${DESTDIR}/${HEADERDIR}/qdecoder.h
+ ${INSTALL_DATA} ${LIBNAME} ${DESTDIR}/${LIBDIR}/${LIBNAME}
+ ${INSTALL_DATA} ${SLIBREALNAME} ${DESTDIR}/${LIBDIR}/${SLIBREALNAME}
+ ( cd ${DESTDIR}/${LIBDIR}; ${LN_S} -f ${SLIBREALNAME} ${SLIBNAME} )
deinstall: uninstall
uninstall:
- ${RM} -f ${HEADERDIR}/qdecoder.h
- ${RM} -f ${LIBDIR}/${LIBNAME}
- ${RM} -f ${LIBDIR}/${SLIBREALNAME}
- ${RM} -f ${LIBDIR}/${SLIBNAME}
+ ${RM} -f ${DESTDIR}/${HEADERDIR}/qdecoder.h
+ ${RM} -f ${DESTDIR}/${LIBDIR}/${LIBNAME}
+ ${RM} -f ${DESTDIR}/${LIBDIR}/${SLIBREALNAME}
+ ${RM} -f ${DESTDIR}/${LIBDIR}/${SLIBNAME}
doc:
doxygen doxygen.conf