buildrootschalter/package/fbgrab/fbgrab-01-fix-static-build.patch
Thomas Petazzoni b8242149e4 fbgrab: fix static linking
Fixes:

  http://autobuild.buildroot.org/results/9e0/9e079632a6c0556c96ec8ed7564286aa84044bf7/
  http://autobuild.buildroot.org/results/401/401105b5e120176e78c2e5fcabe54ab0bde1bf40/
  and more

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2014-05-18 23:32:43 +02:00

22 lines
649 B
Diff

Fix static build
fbgrab links against libpng, which depends on libm. For shared library
builds, there is nothing special to do about this, but for static
library builds, it is necessary to pass -lm when linking fbgrab.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/Makefile
===================================================================
--- a/Makefile
+++ b/Makefile
@@ -12,7 +12,7 @@
all: fbgrab fbgrab.1.gz
fbgrab: fbgrab.c
- $(CC) -g -Wall $(CFLAGS) $(LDFLAGS) $< -lpng -lz -o $@
+ $(CC) -g -Wall $(CFLAGS) $(LDFLAGS) $< -lpng -lz -lm -o $@
fbgrab.1.gz: fbgrab.1.man
$(GZIP) $(GZIPFLAGS) $< > $@