buildrootschalter/package/libevent/libevent-disable-building-test-programs.patch
gilles.talis@gmail.com a213dc6d53 libevent: disable building test programs
Libevent test programs use fork(), function
that is not available on MMU-less architecture.

This patch prevents compiling libevent test programs
so that library can successfully build on architectures
like blackfin

Fixes:
http://autobuild.buildroot.org/results/2e0/2e0422f1042d0cb00f5bab0dc190930581ed4ef2/

Signed-off-by: Gilles Talis <gilles.talis@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
2013-07-02 22:09:15 +02:00

31 lines
1.1 KiB
Diff

From e932c8864e1bb8b6a7901d4b049a1100c4becba5 Mon Sep 17 00:00:00 2001
From: Gilles Talis <gilles.talis@gmail.com>
Date: Fri, 21 Jun 2013 15:25:11 -0700
Subject: [PATCH] Disable building test programs
We are not really interested in building test programs.
Moreover, these programs use fork() function that is
not available on MMU-less architectures.
Signed-off-by: Gilles Talis <gilles.talis@gmail.com>
---
Makefile.in | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/Makefile.in b/Makefile.in
index 2ebefa2..4fba1ff 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -487,7 +487,7 @@ LIBEVENT_LIBS_LA = libevent.la libevent_core.la libevent_extra.la \
@INSTALL_LIBEVENT_TRUE@lib_LTLIBRARIES = $(LIBEVENT_LIBS_LA)
@INSTALL_LIBEVENT_TRUE@pkgconfig_DATA = $(LIBEVENT_PKGCONFIG)
@INSTALL_LIBEVENT_FALSE@noinst_LTLIBRARIES = $(LIBEVENT_LIBS_LA)
-SUBDIRS = . include sample test
+SUBDIRS = . include sample
@BUILD_WIN32_FALSE@SYS_LIBS =
@BUILD_WIN32_TRUE@SYS_LIBS = -lws2_32 -lshell32 -ladvapi32
@BUILD_WIN32_FALSE@SYS_SRC = $(am__append_5) $(am__append_6) \
--
1.7.4.1