buildrootschalter/package/libtirpc/libtirpc-0004-Make-IPv6-support-optional.patch
Thomas Petazzoni 9346b1b979 libtirpc: remove patch numbers from patch titles
The patch numbers in [PATCH x/y] are quite useless within the context
of Buildroot, and generate noise when patches are re-ordered.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
2012-11-14 22:57:56 +01:00

44 lines
1.3 KiB
Diff

From 5ce585bed328fafc99800effb5e9d1b07dbac2b7 Mon Sep 17 00:00:00 2001
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Date: Sun, 24 Jun 2012 21:40:21 +0200
Subject: [PATCH] Make IPv6 support optional
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
configure.ac | 5 +++++
src/Makefile.am | 2 +-
2 files changed, 6 insertions(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index 97c6f2c..487ec83 100644
--- a/configure.ac
+++ b/configure.ac
@@ -22,6 +22,11 @@ AC_PROG_LIBTOOL
AC_HEADER_DIRENT
AC_PREFIX_DEFAULT(/usr)
AC_CHECK_HEADERS([arpa/inet.h fcntl.h libintl.h limits.h locale.h netdb.h netinet/in.h stddef.h stdint.h stdlib.h string.h sys/ioctl.h sys/param.h sys/socket.h sys/time.h syslog.h unistd.h])
+
+AC_CHECK_HEADER(netinet/ip6.h,
+ AC_DEFINE(INET6, 1, [Define to 1 if IPv6 is available]),
+ [AC_MSG_WARN([no IPv6])])
+
AC_CHECK_LIB([pthread], [pthread_create])
diff --git a/src/Makefile.am b/src/Makefile.am
index 6d36b93..6dc259e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -6,7 +6,7 @@
## anything like that.
-INCLUDES = -I$(top_srcdir)/tirpc -DPORTMAP -DINET6 -DVERSION="\"$(VERSION)\"" \
+INCLUDES = -I$(top_srcdir)/tirpc -DPORTMAP -DVERSION="\"$(VERSION)\"" \
-D_GNU_SOURCE -Wall -pipe
lib_LTLIBRARIES = libtirpc.la
--
1.7.9.5