buildrootschalter/package/xstroke/xstroke-fix-link-issues.patch
Thomas Petazzoni 0ef90a63e8 xstroke: fix link issue
The allyespackageconfig builds have trigerred a link issue on
xstroke. In fact, xstroke must be linked against Xrender, Xext and dl
in addition to the other libraries it was already be linked
against. We fix that by adding a patch that modifies configure.ac and
Makefile.am, and enabling autoreconf for this package.

In addition, since xstroke uses directly Xrender and Xext, we add
those dependencies to the package. In practice, it doesn't change
anything, since some of the xstroke dependencies were already pulling
those libraries, but as xstroke uses directly Xrender and Xext, it
makes sense to have them as dependencies as well.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
2012-12-18 21:40:22 +01:00

36 lines
1.3 KiB
Diff

Fix link issues by linking against all needed libraries
Since gcc 4.6, all libraries that are directly used must be explicitly
passed on the command line. In the case of xstroke, linking against
Xrender, Xext and dl was missing. For the first two, they are added
through addition PKG_CHECK_MODULES() checks, for the latter, it is
added next to -lm and -lpthread in Makefile.am.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/Makefile.am
===================================================================
--- a/Makefile.am
+++ b/Makefile.am
@@ -40,7 +40,7 @@
BUILT_SOURCES = rec_parse.h rec_lex.h rec_lex.c
AM_YFLAGS = -d
-xstroke_LDADD = @XSTROKE_LIBS@ -lm -lpthread $(X_LIBS) -lXpm -lXtst
+xstroke_LDADD = @XSTROKE_LIBS@ -ldl -lm -lpthread $(X_LIBS) -lXpm -lXtst
AM_CFLAGS = @XSTROKE_CFLAGS@ -DXSTROKE_CONF_DIR='"$(sysconfdir)/xstroke"' $(X_CFLAGS)
EXTRA_DIST = xstroke_active.xpm xstroke_inactive.xpm etc/alphabet
Index: b/configure.ac
===================================================================
--- a/configure.ac
+++ b/configure.ac
@@ -26,7 +26,7 @@
AC_CHECK_FUNCS([gettimeofday localtime_r])
AC_PATH_XTRA
-PKG_CHECK_MODULES(XSTROKE, xft)
+PKG_CHECK_MODULES(XSTROKE, [xft xrender xext])
AC_CONFIG_FILES([Makefile])
AC_OUTPUT