buildrootschalter/package/poppler/0001-Fix-invalid-shell-comparaison-in-libtiff-test.patch
Thomas Petazzoni bc8423a8d4 poppler: add patch to fix invalid syntax in configure script
When configuring poppler, a shell error occurs:

./configure: line 19741: test: x: unary operator expected

This is due to an invalid configure test, which is fixed by a newly
added patch. We patch the configure script directly because poppler
doesn't autoreconf properly. A patch on configure.ac has been
submitted upstream so that hopefully we can drop our patch in a future
release of poppler.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2015-05-03 16:33:46 +02:00

24 lines
740 B
Diff

Fix syntax issue in configure script
The change is not done in configure.ac, because the package doesn't
autoreconf properly.
Patch on configure.ac submitted upstream at
https://bugs.freedesktop.org/show_bug.cgi?id=90292.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/configure
===================================================================
--- a/configure
+++ b/configure
@@ -19738,7 +19738,7 @@
CXXFLAGS="$CXXFLAGS $LIBTIFF_CFLAGS"
LIBS="$LIBS $LIBTIFF_LIBS"
if test x$enable_libtiff = xyes; then
- if test x"$LIBTIFF_LIBS" != ; then
+ if test x"$LIBTIFF_LIBS" != x; then
ac_fn_cxx_check_func "$LINENO" "TIFFOpen" "ac_cv_func_TIFFOpen"
if test "x$ac_cv_func_TIFFOpen" = xyes; then :