buildrootschalter/package/zlib/zlib-1.2.5-fix-static-install.patch
Peter Korsgaard cc37a07f28 zlib: really fix install for static only builds
Commit ab2f5567c1 (cleanup, fix install for static only build) forgot
to add the patch for static only builds, even though the commit message
mentioned it.

Thanks to Mike for noticing.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
2010-12-12 08:51:58 +01:00

25 lines
997 B
Diff

[PATCH] fix make install for static builds
Only try to install shared lib if we've built one.
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
---
Makefile.in | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
Index: zlib-1.2.5/Makefile.in
===================================================================
--- zlib-1.2.5.orig/Makefile.in
+++ zlib-1.2.5/Makefile.in
@@ -168,7 +168,9 @@ install-libs: $(LIBS)
-@if [ ! -d $(DESTDIR)$(man3dir) ]; then mkdir -p $(DESTDIR)$(man3dir); fi
-@if [ ! -d $(DESTDIR)$(pkgconfigdir) ]; then mkdir -p $(DESTDIR)$(pkgconfigdir); fi
cp $(STATICLIB) $(DESTDIR)$(libdir)
- cp $(SHAREDLIBV) $(DESTDIR)$(sharedlibdir)
+ if test "$(SHAREDLIBV)" -a -f $(SHAREDLIBV); then \
+ cp $(SHAREDLIBV) $(DESTDIR)$(sharedlibdir); \
+ fi
cd $(DESTDIR)$(libdir); chmod u=rw,go=r $(STATICLIB)
-@(cd $(DESTDIR)$(libdir); $(RANLIB) libz.a || true) >/dev/null 2>&1
-@cd $(DESTDIR)$(sharedlibdir); if test "$(SHAREDLIBV)" -a -f $(SHAREDLIBV); then \