buildrootschalter/package/libpcap/libpcap-remove-libnl-include-path.patch
Thomas Petazzoni 205643a345 libpcap: fix build failure related to libnl3
When libpcap detects that libnl3 is available, it hardcodes the fact
of using -I/usr/include/libnl3, which is completely wrong in
cross-compilation.

This commit fixes that, by removing this hardcoded include path, and
by passing an appropriate -I option from libpcap.mk.

The original issue has been reported upstream at
https://github.com/the-tcpdump-group/libpcap/issues/305.

Fixes:

  http://autobuild.buildroot.net/results/b65/b6585bf2985a188e797e5a6b71a35c461421e3b4/build-end.log

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
2013-06-09 20:32:40 +02:00

17 lines
539 B
Diff

Remove hardcoded path to libnl3 include directory
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/configure.in
===================================================================
--- a/configure.in
+++ b/configure.in
@@ -445,7 +445,6 @@
AC_DEFINE(HAVE_LIBNL_3_x,1,[if libnl exists and is version 3.x])
AC_DEFINE(HAVE_LIBNL_NLE,1,[libnl has NLE_FAILURE])
AC_DEFINE(HAVE_LIBNL_SOCKETS,1,[libnl has new-style socket api])
- V_INCLS="$V_INCLS -I/usr/include/libnl3"
have_any_nl="yes"
])