buildrootschalter/package/pcmanfm/pcmanfm-link-against-libx11.patch
Thomas Petazzoni a831505a3d pcmanfm: link against libX11 to avoid build failure
Fixes:

/home/test/outputs/allpkg/host/opt/ext-toolchain/bin/../lib/gcc/arm-linux-gnueabihf/4.7.3/../../../../arm-linux-gnueabihf/bin/ld: fm-desktop.o: undefined reference to symbol 'XSendEvent'
/home/test/outputs/allpkg/host/opt/ext-toolchain/bin/../lib/gcc/arm-linux-gnueabihf/4.7.3/../../../../arm-linux-gnueabihf/bin/ld: note: 'XSendEvent' is defined in DSO /home/test/outputs/allpkg/host/usr/arm-buildroot-linux-gnueabi/sysroot/usr/lib/libX11.so.6 so try adding it to the linker command line
/home/test/outputs/allpkg/host/usr/arm-buildroot-linux-gnueabi/sysroot/usr/lib/libX11.so.6: could not read symbols: Invalid operation
collect2: error: ld returned 1 exit status
make[4]: *** [pcmanfm] Error 1

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
2012-12-19 14:49:14 +01:00

21 lines
484 B
Diff

Link against libX11
fm-desktop.c uses XSendEvent, so we should link against libX11.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/configure.in
===================================================================
--- a/configure.in
+++ b/configure.in
@@ -12,7 +12,8 @@
pkg_modules="gtk+-2.0 >= 2.6.0 \
gthread-2.0 \
- libstartup-notification-1.0"
+ libstartup-notification-1.0 \
+ x11"
AC_FUNC_MMAP