buildrootschalter/package/monit/monit-0001-no-force-static.patch
Yann E. MORIN 03f388619a package/monit: do not forcibly build a static binary
Static linking with glibc is not really supported, because of the NSS
libraries that are still to be dynamically-loaded at runtime.

Also, Buildroot explicitly does not support statically linking with
glibc.

Reported-by: Peter Kümmel <syntheticpp@gmx.net>
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2014-09-06 23:31:20 +02:00

21 lines
635 B
Diff

Do not force building a statically-linked binary
Statically-linked binary do not work well with glibc, because it
still dlopen()s the NSS libraries.
Reported-by: Peter Kümmel <syntheticpp@gmx.net>
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
diff -durN monit-5.7.orig/Makefile.am monit-5.7/Makefile.am
--- monit-5.7.orig/Makefile.am 2014-02-20 09:00:42.000000000 +0100
+++ monit-5.7/Makefile.am 2014-09-05 12:49:43.711104001 +0200
@@ -85,7 +85,7 @@
src/process/sysdep_@ARCH@.c
monit_LDADD = libmonit/libmonit.la
-monit_LDFLAGS = -static $(EXTLDFLAGS)
+monit_LDFLAGS = $(EXTLDFLAGS)
man_MANS = monit.1