buildrootschalter/package/hplip/hplip-fix-make.patch
Olivier Schonken aeb1bbabe3 Added package HPLIP for printing to HP printers
HPLIP (Hewlett-Packard Linux Imaging & Printing) is an HP-developed solution
for printing, scanning, and faxing with HP inkjet and laser based printers
in Linux.

[Peter: fix Config.in white space]
Signed-off-by: Olivier Schonken <olivier.schonken@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
2013-03-19 13:07:39 +01:00

75 lines
3.1 KiB
Diff

From 6019d012246578ae1a191d3510284e7b894fb528 Mon Sep 17 00:00:00 2001
From: Olivier Schonken <olivier.schonken@gmail.com>
Date: Sat, 2 Mar 2013 18:01:03 +0200
Subject: [PATCH] Changed Makefile.am to allow cross-compilation of HPLIP
Signed-off-by: Olivier Schonken <olivier.schonken@gmail.com>
---
Makefile.am | 28 ++++++++++++++--------------
1 file changed, 14 insertions(+), 14 deletions(-)
diff --git a/Makefile.am b/Makefile.am
index 16ea902..b22f46a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -72,7 +72,7 @@ libhpmud_la_SOURCES = io/hpmud/hpmud.c io/hpmud/mlc.c io/hpmud/model.c io/hpmud/
io/hpmud/hpmud.h io/hpmud/hpmudi.h io/hpmud/list.h io/hpmud/mlc.h io/hpmud/pml.h io/hpmud/dot4.c \
io/hpmud/dot4.h io/hpmud/jd.c io/hpmud/jd.h io/hpmud/pp.c io/hpmud/pp.h io/hpmud/musb.h io/hpmud/musb_libusb01.c
else
-libhpmud_la_CFLAGS = -I/usr/include/libusb-1.0 -DMUDNAME=\"$(MUDNAME)\" -DCONFDIR=\"$(hplip_confdir)\"
+libhpmud_la_CFLAGS = -I$(includedir)/libusb-1.0 -DMUDNAME=\"$(MUDNAME)\" -DCONFDIR=\"$(hplip_confdir)\"
libhpmud_la_SOURCES = io/hpmud/hpmud.c io/hpmud/mlc.c io/hpmud/model.c io/hpmud/pml.c \
io/hpmud/hpmud.h io/hpmud/hpmudi.h io/hpmud/list.h io/hpmud/mlc.h io/hpmud/pml.h io/hpmud/dot4.c \
io/hpmud/dot4.h io/hpmud/jd.c io/hpmud/jd.h io/hpmud/pp.c io/hpmud/pp.h io/hpmud/musb.h io/hpmud/musb.c
@@ -292,7 +292,7 @@ hpmudext_la_LIBADD = libhpmud.la
if LIBUSB01_BUILD
hpmudext_la_CFLAGS = -I$(PYTHONINCLUDEDIR)
else
-hpmudext_la_CFLAGS =-I/usr/include/libusb-1.0 -I$(PYTHONINCLUDEDIR)
+hpmudext_la_CFLAGS =-I$(includedir)/libusb-1.0 -I$(PYTHONINCLUDEDIR)
endif
# ui (qt3)
@@ -564,26 +564,26 @@ endif
install-dist_hplip_LogDATA:
if FULL_BUILD
- test -z "$(DESTDIR)$(hplip_Logdir)" || mkdir -p $(DESTDIR)$(hplip_Logdir)
- chgrp "lp" -R $(DESTDIR)$(hplip_Logdir)
- chmod 775 $(DESTDIR)$(hplip_Logdir)
+# test -z "$(DESTDIR)$(hplip_Logdir)" || mkdir -p $(DESTDIR)$(hplip_Logdir)
+# chgrp "lp" -R $(DESTDIR)$(hplip_Logdir)
+# chmod 775 $(DESTDIR)$(hplip_Logdir)
endif #FULL_BUILD
if HPLIP_BUILD
- test -z "$(DESTDIR)$(hplip_Logdir)" || mkdir -p $(DESTDIR)$(hplip_Logdir)
- chgrp "lp" -R $(DESTDIR)$(hplip_Logdir)
- chmod 775 $(DESTDIR)$(hplip_Logdir)
+# test -z "$(DESTDIR)$(hplip_Logdir)" || mkdir -p $(DESTDIR)$(hplip_Logdir)
+# chgrp "lp" -R $(DESTDIR)$(hplip_Logdir)
+# chmod 775 $(DESTDIR)$(hplip_Logdir)
endif #FULL_BUILD
install-dist_hplip_tmpDATA:
if FULL_BUILD
- test -z "$(DESTDIR)$(hplip_tmpdir)" || mkdir -p $(DESTDIR)$(hplip_tmpdir)
- chgrp "lp" -R $(DESTDIR)$(hplip_tmpdir)
- chmod 1775 $(DESTDIR)$(hplip_tmpdir)
+# test -z "$(DESTDIR)$(hplip_tmpdir)" || mkdir -p $(DESTDIR)$(hplip_tmpdir)
+# chgrp "lp" -R $(DESTDIR)$(hplip_tmpdir)
+# chmod 1775 $(DESTDIR)$(hplip_tmpdir)
endif #FULL_BUILD
if HPLIP_BUILD
- test -z "$(DESTDIR)$(hplip_tmpdir)" || mkdir -p $(DESTDIR)$(hplip_tmpdir)
- chgrp "lp" -R $(DESTDIR)$(hplip_tmpdir)
- chmod 1775 $(DESTDIR)$(hplip_tmpdir)
+# test -z "$(DESTDIR)$(hplip_tmpdir)" || mkdir -p $(DESTDIR)$(hplip_tmpdir)
+# chgrp "lp" -R $(DESTDIR)$(hplip_tmpdir)
+# chmod 1775 $(DESTDIR)$(hplip_tmpdir)
endif #FULL_BUILD
install-dist_cronDATA:$(dist_cron_DATA)
--
1.7.10.4