buildrootschalter/package/sdl/sdl-use-correct-directfb-config.patch
Peter Korsgaard 1655f3c5b7 sdl: fix directfb configure check
The configure script nicely supports a preconfigured directfb-config
(using ac_cv_path_DIRECTFBCONFIG), except for when it checks the directfb
version where it simply uses whatever directfb-config is in the path,
breaking the build when this isn't available / recent enough.

Fix is to use the correct one instead. As SDL doesn't autoreconf cleanly,
also patch the generated configure script.

Finally move the ac_cv_path_DIRECTFBCONFIG setting under the directfb
conditional as it is only needed there.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
2013-04-28 22:32:39 +02:00

41 lines
1.7 KiB
Diff

[PATCH] configure.in: use correct directfb-config in version check
The configure script has just checked for the correct directfb-config
script, so also use it for the version check instead of whatever
might be in the path.
Also patch the generated configure, as it doesn't cleanly autoreconf.
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
---
configure | 2 +-
configure.in | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
Index: SDL-1.2.15/configure.in
===================================================================
--- SDL-1.2.15.orig/configure.in
+++ SDL-1.2.15/configure.in
@@ -1276,7 +1276,7 @@
else
set -- `echo $DIRECTFB_REQUIRED_VERSION | sed 's/\./ /g'`
NEED_VERSION=`expr $1 \* 10000 + $2 \* 100 + $3`
- set -- `directfb-config --version | sed 's/\./ /g'`
+ set -- `$DIRECTFBCONFIG --version | sed 's/\./ /g'`
HAVE_VERSION=`expr $1 \* 10000 + $2 \* 100 + $3`
if test $HAVE_VERSION -ge $NEED_VERSION; then
DIRECTFB_CFLAGS=`$DIRECTFBCONFIG --cflags`
Index: SDL-1.2.15/configure
===================================================================
--- SDL-1.2.15.orig/configure
+++ SDL-1.2.15/configure
@@ -24958,7 +24958,7 @@
else
set -- `echo $DIRECTFB_REQUIRED_VERSION | sed 's/\./ /g'`
NEED_VERSION=`expr $1 \* 10000 + $2 \* 100 + $3`
- set -- `directfb-config --version | sed 's/\./ /g'`
+ set -- `$DIRECTFBCONFIG --version | sed 's/\./ /g'`
HAVE_VERSION=`expr $1 \* 10000 + $2 \* 100 + $3`
if test $HAVE_VERSION -ge $NEED_VERSION; then
DIRECTFB_CFLAGS=`$DIRECTFBCONFIG --cflags`