buildrootschalter/package/python/python-2.7-016-cross-compile-getaddrinfo.patch
vsergeev 94c297c448 python: enable IPv6 socket support
Added patch to disable buggy_getaddrinfo test during configure when
cross-compiling.

[Peter: Remove --enable-ipv6 which is now handled globally]
Signed-off-by: Vanya Sergeev <vsergeev at gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
2012-04-24 22:57:05 +02:00

16 lines
546 B
Diff

Disable buggy_getaddrinfo configure test when cross-compiling with IPv6 support
Signed-off-by: Vanya Sergeev <vsergeev at gmail.com>
--- python-2.7.2.orig/configure.in 2012-04-22 06:52:09.361809545 -0400
+++ python-2.7.2/configure.in 2012-04-22 06:56:37.900634194 -0400
@@ -3128,7 +3128,7 @@
AC_MSG_RESULT($ac_cv_buggy_getaddrinfo)
-if test $have_getaddrinfo = no -o "$ac_cv_buggy_getaddrinfo" = yes
+if test $have_getaddrinfo = no || test "$cross_compiling" != "yes" -a "$ac_cv_buggy_getaddrinfo" = yes
then
if test $ipv6 = yes
then