buildrootschalter/package/libfcgi/libfcgi-link-against-math.patch
Thomas Petazzoni 4326f0020d libfcgi: fix build problem of libfcgi++
Fix the way libfcgi++ is linked against libfcgi to solve the
http://autobuild.buildroot.org/results/f8e88e93f32e4e94ac9aef5a3f3f2826f1970453/build-end.log
build problem.

Since we're fixing Makefile.am, take that opportunity to add -lm where
needed, to avoid the need of using custom LDFLAGS in libfcgi.mk.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
2012-05-06 17:39:15 +02:00

29 lines
812 B
Diff

Link against math libraries when needed
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/cgi-fcgi/Makefile.am
===================================================================
--- a/cgi-fcgi/Makefile.am
+++ b/cgi-fcgi/Makefile.am
@@ -11,5 +11,5 @@
LIBDIR = ../libfcgi
LIBFCGI = $(LIBDIR)/libfcgi.la
-LDADD = $(LIBFCGI)
+LDADD = $(LIBFCGI) -lm
cgi_fcgi_SOURCES = $(INCLUDE_FILES) cgi-fcgi.c
Index: b/examples/Makefile.am
===================================================================
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -21,7 +21,7 @@
LIBDIR = ../libfcgi
LIBFCGI = $(LIBDIR)/libfcgi.la
-LDADD = $(LIBFCGI)
+LDADD = $(LIBFCGI) -lm
echo_SOURCES = $(INCLUDE_FILES) echo.c
echo_x_SOURCES = $(INCLUDE_FILES) echo-x.c