buildrootschalter/package/libfcgi/libfcgi-link-against-libfcgi-la.patch
Thomas Petazzoni 4326f0020d libfcgi: fix build problem of libfcgi++
Fix the way libfcgi++ is linked against libfcgi to solve the
http://autobuild.buildroot.org/results/f8e88e93f32e4e94ac9aef5a3f3f2826f1970453/build-end.log
build problem.

Since we're fixing Makefile.am, take that opportunity to add -lm where
needed, to avoid the need of using custom LDFLAGS in libfcgi.mk.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
2012-05-06 17:39:15 +02:00

21 lines
751 B
Diff

Properly link libfcgi++ against libfcgi
We cannot directly use -lfcgi to link libfcgi++ against libfcgi,
because libfcgi is not installed at this time. Instead, we should rely
on libtool doing the right thing, by specifying libfcgi.la in
libfcgi++ LIBADD variable.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/libfcgi/Makefile.am
===================================================================
--- a/libfcgi/Makefile.am
+++ b/libfcgi/Makefile.am
@@ -23,5 +23,6 @@
$(INCLUDEDIR)/fcgio.h \
fcgio.cpp
libfcgi___la_CFLAGS = @PTHREAD_CFLAGS@
-libfcgi___la_LDFLAGS = -lfcgi -rpath @libdir@
+libfcgi___la_LIBADD = libfcgi.la
+libfcgi___la_LDFLAGS = -rpath @libdir@