buildrootschalter/support/kconfig/patches/15-fix-qconf-moc-rule.patch
Yann E. MORIN b48e35a28a support/kconfig: bump to kconfig from linux-3.12
With this, we can trash our probability patch, it's now upstream.
Refresh a few other patches.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2013-11-14 12:34:49 +01:00

25 lines
653 B
Diff

Fix the rule that generates the .moc file
The Linux kernel has a "cmd" make function, but we don't have it in
Buildroot, so we need to adjust this rule.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/Makefile
===================================================================
--- a/Makefile
+++ b/Makefile
@@ -309,11 +309,8 @@
$(obj)/qconf.o: $(obj)/qconf.moc
-quiet_cmd_moc = MOC $@
- cmd_moc = $(KC_QT_MOC) -i $< -o $@
-
$(obj)/%.moc: $(src)/%.h $(obj)/.tmp_qtcheck
- $(call cmd,moc)
+ $(KC_QT_MOC) -i $< -o $@
# Extract gconf menu items for I18N support
$(obj)/gconf.glade.h: $(obj)/gconf.glade