buildrootschalter/package/usb_modeswitch/usb_modeswitch-makefile.patch
J.C. Woltz 1fc66acff8 usb_modeswitch: update to 1.2.4
This patch updates usb_modeswitch to version 1.2.4. The
usb_modeswitch.mk needed to be modified for usb_modeswitch to compile.
Also added extra remove section for the added help scripts and files.

[thomas.petazzoni@free-electrons.com:
  bumped further to 1.2.4 instead of 1.2.3, adjusted the patch accordingly
  use TARGET_CONFIGURE_OPTS instead of passing CC, LD manually
  add license information.]

Signed-off-by: J.C. Woltz <jwoltz@gmail.com>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2012-08-12 19:00:29 +02:00

32 lines
1.2 KiB
Diff

Removed the -s from the install command. Without this, usb_modeswitch would
fail to install.
Signed-off-by: J.C. Woltz <jwoltz@gmail.com>
Index: b/Makefile
===================================================================
--- a/Makefile
+++ b/Makefile
@@ -46,7 +46,7 @@
cd jim && $(MAKE) distclean
install-common: all
- install -D -s --mode=755 usb_modeswitch $(SBINDIR)/usb_modeswitch
+ install -D --mode=755 usb_modeswitch $(SBINDIR)/usb_modeswitch
install -D --mode=755 usb_modeswitch.sh $(UDEVDIR)/usb_modeswitch
install -D --mode=644 usb_modeswitch.conf $(ETCDIR)/usb_modeswitch.conf
install -D --mode=644 usb_modeswitch.1 $(MANDIR)/usb_modeswitch.1
@@ -67,10 +67,10 @@
install: install-common install-script
install-shared: dispatcher-dynamic install-common
- install -D -s --mode=755 usb_modeswitch_dispatcher $(SBINDIR)/usb_modeswitch_dispatcher
+ install -D --mode=755 usb_modeswitch_dispatcher $(SBINDIR)/usb_modeswitch_dispatcher
install-static: dispatcher-static install-common
- install -D -s --mode=755 usb_modeswitch_dispatcher $(SBINDIR)/usb_modeswitch_dispatcher
+ install -D --mode=755 usb_modeswitch_dispatcher $(SBINDIR)/usb_modeswitch_dispatcher
uninstall:
$(RM) $(SBINDIR)/usb_modeswitch