buildrootschalter/package/python-nfc/python-nfc-add-setup-py.patch
Simon Dawson 5b1e84b6e0 python-nfc: fix autobuild failures
Fixes autobuild failures such as the following.

  http://autobuild.buildroot.net/results/2e1/2e11b9e946a854deb28ba144ca7e398a9c996a02/

Signed-off-by: Simon Dawson <spdawson@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2014-01-12 21:14:16 +01:00

27 lines
745 B
Diff

Add simple setup.py
Having a setup.py allows to easily get the .py files compiled into
.pyc, which is good because by default, Buildroot only keeps .pyc
files on the target.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/setup.py
===================================================================
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,13 @@
+#!/usr/bin/env python
+
+from distutils.core import setup
+
+setup(name='NFC',
+ version='1.0',
+ description='Python NFC',
+ author='Stephen Tiedemann',
+ author_email='stephen.tiedemann@googlemail.com',
+ url='https://launchpad.net/nfcpy',
+ packages=['nfc', 'nfc/dev', 'nfc/llcp', 'nfc/ndef',
+ 'nfc/snep'],
+ )