buildrootschalter/package/json-c/json-c-no-reentrant.patch
Thomas Petazzoni ecd0f65af9 json-c: bump to version 0.11
Bumping this package is needed, because json-c 0.10 has a major
defect: it installs a library named libjson.so, which conflicts with
the library installed by the libjson package.

This has been changed in the upstream json-c 0.11 version, which now
installs libjson-c and json-c.pc.

It allows to solve the Pulseaudio link problem, which wants to link
against json-c but happens to link against libjson when libjson has
been compiled and installed after json-c.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
2013-05-10 20:41:39 +02:00

45 lines
1.8 KiB
Diff

Do not pass -D_REENTRANT
This flag is not needed to build this library, and prevents to build
it with toolchains that don't have thread support.
Since the Makefile.in change is a one-liner, we also do it in the
patch to avoid having to autoreconfigure the package.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/Makefile.am.inc
===================================================================
--- a/Makefile.am.inc
+++ b/Makefile.am.inc
@@ -1,2 +1,2 @@
-AM_CFLAGS = -Wall -Werror -Wextra -Wwrite-strings -Wno-unused-parameter -std=gnu99 -D_GNU_SOURCE -D_REENTRANT
+AM_CFLAGS = -Wall -Werror -Wextra -Wwrite-strings -Wno-unused-parameter -std=gnu99 -D_GNU_SOURCE
Index: b/Makefile.in
===================================================================
--- a/Makefile.in
+++ b/Makefile.in
@@ -274,7 +274,7 @@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
-AM_CFLAGS = -Wall -Werror -Wextra -Wwrite-strings -Wno-unused-parameter -std=gnu99 -D_GNU_SOURCE -D_REENTRANT
+AM_CFLAGS = -Wall -Werror -Wextra -Wwrite-strings -Wno-unused-parameter -std=gnu99 -D_GNU_SOURCE
EXTRA_DIST = README.html README-WIN32.html config.h.win32 doc json-c.vcproj
SUBDIRS = . tests
lib_LTLIBRARIES = libjson-c.la $(am__append_1)
Index: b/tests/Makefile.in
===================================================================
--- a/tests/Makefile.in
+++ b/tests/Makefile.in
@@ -228,7 +228,7 @@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
-AM_CFLAGS = -Wall -Werror -Wextra -Wwrite-strings -Wno-unused-parameter -std=gnu99 -D_GNU_SOURCE -D_REENTRANT
+AM_CFLAGS = -Wall -Werror -Wextra -Wwrite-strings -Wno-unused-parameter -std=gnu99 -D_GNU_SOURCE
LIBJSON_LA = $(top_builddir)/libjson-c.la
test1_LDADD = $(LIBJSON_LA)
test1Formatted_LDADD = $(LIBJSON_LA)