buildrootschalter/package/xbmc/xbmc-0001-Fixup-include-path.patch
Maxime Hadjinlian a85c452a2d xbmc: new package
XBMC is an award-winning free and open source (GPL) software media
player and entertainment hub for digital media.

We do provide a sub-option for each major feature we support, to avoid
letting the user hunt-down required libraries, since the dependency is
not always obvious and straightforward.

We also provide our own wrapper script, because the ones bundled in
XBMC are not suitable to all platforms. We need such a wrapper script
because XBMC exits with different exit codes, depending on how the user
quit XBMC: 0 is normal exit, 64 is for halt, and 66 is for reboot. So
we can't simply call the real XBMC binary from the startup script, or
we would lose this information. So, we provide a wrapper script that
takes appropriate action according to the above exit codes.

When run as root from a startup script, there is no HOME set, so XBMC
defaults to saving its configuration in /.xbmc (yes, at the root of the
rootfs). Since this does not play well with read-only filesystems (and
is inherently ugly anyway), and sicne there is no real clean way to tell
XBMC where to store its configuration, just provide a symlink to a better
place: /.xbmc -> /var/xbmc  (note: the only location _guaranteed_ to be
writable is /tmp, but we want the configuration to survive a reboot. So,
/var/xbmc looks a better place than /var/run/xbmc. and the user will
have to take action to ensure /var/xbmc be writable.) (note: for this
reason, we do not want to set $HOME to /root either, even if it is root
running XBMC.)

Some of XBMC sub-options select libraries that depend on toolchain options,
such as IPv6. But those are already covered, being also implicit
dependencies of XBMC, as XBMC can only be used on an (e)glibc toolchain
anyway. When^WIf XBMC is one day buildable under uClibc/musl, this will be
time to revisit those dependencies.

This package was originally found at : https://github.com/huceke/buildroot-rbp
By gimli <ebsi4711@gmail.com>

Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: gimli <ebsi4711@gmail.com>
Cc: Martin Bark <martin@barkynet.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2014-03-27 00:17:07 +01:00

82 lines
2.6 KiB
Diff

From 63c255f1f5d68363f49193aceed343e602dc8bdf Mon Sep 17 00:00:00 2001
From: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Date: Thu, 26 Dec 2013 21:17:10 +0100
Subject: [PATCH] Fixup include path
Patch originally taken from :
http://repository.timesys.com/buildsources/x/xbmc/xbmc-11.0/xbmc-11.0-fixups.patch
Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
---
lib/enca/configure | 3 ---
lib/enca/configure.ac | 3 ---
lib/libdvd/libdvdread/misc/dvdread-config.sh | 6 +++---
lib/timidity/configure.in | 6 +++---
4 files changed, 6 insertions(+), 12 deletions(-)
diff --git a/lib/enca/configure b/lib/enca/configure
index c839a51..7af5a09 100644
--- a/lib/enca/configure
+++ b/lib/enca/configure
@@ -12011,9 +12011,6 @@ fi
if test "$prefix" = "NONE"; then
LDFLAGS="$LDFLAGS -L$ac_default_prefix/lib"
CPPFLAGS="$CPPFLAGS -I$ac_default_prefix/include"
-else
- LDFLAGS="$LDFLAGS -L$prefix/lib"
- CPPFLAGS="$CPPFLAGS -I$prefix/include"
fi
diff --git a/lib/enca/configure.ac b/lib/enca/configure.ac
index 41434df..47d5367 100644
--- a/lib/enca/configure.ac
+++ b/lib/enca/configure.ac
@@ -100,9 +100,6 @@ dnl Dirty path hack. Helps some people with badly set up search paths.
if test "$prefix" = "NONE"; then
LDFLAGS="$LDFLAGS -L$ac_default_prefix/lib"
CPPFLAGS="$CPPFLAGS -I$ac_default_prefix/include"
-else
- LDFLAGS="$LDFLAGS -L$prefix/lib"
- CPPFLAGS="$CPPFLAGS -I$prefix/include"
fi
dnl Checks for libraries.
diff --git a/lib/libdvd/libdvdread/misc/dvdread-config.sh b/lib/libdvd/libdvdread/misc/dvdread-config.sh
index e170c7e..25ee893 100644
--- a/lib/libdvd/libdvdread/misc/dvdread-config.sh
+++ b/lib/libdvd/libdvdread/misc/dvdread-config.sh
@@ -48,9 +48,9 @@ if test "$echo_prefix" = "yes"; then
fi
if test "$echo_cflags" = "yes"; then
- echo -I$prefix/include $extracflags
+ echo $extracflags
fi
if test "$echo_libs" = "yes"; then
- echo -L$libdir $dvdreadlib
-fi
+ echo $dvdreadlib
+fi
diff --git a/lib/timidity/configure.in b/lib/timidity/configure.in
index 9f2835b..733470a 100644
--- a/lib/timidity/configure.in
+++ b/lib/timidity/configure.in
@@ -100,9 +100,9 @@ done
# add $prefix if specified.
if test "x$prefix" != xNONE -a "x$prefix" != "x$ac_default_prefix" -a "x$prefix" != "x/usr"; then
- LDFLAGS="-L$prefix/lib $LDFLAGS"
- SHLDFLAGS="-L$prefix/lib $SHLDFLAGS"
- CPPFLAGS="-I$prefix/include $CPPFLAGS"
+ LDFLAGS="$LDFLAGS"
+ SHLDFLAGS="$SHLDFLAGS"
+ CPPFLAGS="$CPPFLAGS"
fi
dnl add --with-includes, --with-libraries
--
1.8.5.2