buildrootschalter/package/libcec/libcec-0002-no-psabi-warning.patch
Thomas Petazzoni a5dbc10a7f libcec: fix build issue on AVR32
Fixes:

  http://autobuild.buildroot.org/results/89d/89d8165b455cd7131e4c0729cec50dad8980ceb1/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2014-05-12 22:18:26 +02:00

23 lines
722 B
Diff

Do not use -Wno-psabi warning, not available on old g++
AVR32 uses a very old g++ version, which does not implement the
-Wno-psabi warning flag. This patch simply removes this warning flag
from the libcec build. It can be dropped if only gcc 4.5+ versions are
supported in Buildroot.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/configure.ac
===================================================================
--- a/configure.ac
+++ b/configure.ac
@@ -130,7 +130,7 @@
use_udev="no"
use_adapter_detection="yes"
use_lockdev="no"
-SUPPRESS_MANGLING_WARNINGS=" -Wno-psabi"
+SUPPRESS_MANGLING_WARNINGS=""
case "${host}" in
*-*-linux*)
## search for udev if pkg-config was found