buildrootschalter/boot/syslinux/syslinux-build-fix-for-uuid.patch
Aras Vaichas d2ff1ac2b3 syslinux: bump to 4.05
* bump syslinux from 4.04 to 4.05
* add patch to fix build problem with 4.05, see
http://old.nabble.com/syslinux-fails-to-build-td34112447.html
* add util-linux dependency and make sure the build finds it

Signed-off-by: Aras Vaichas <aras.vaichas@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2012-07-17 19:45:06 +02:00

16 lines
579 B
Diff

Author: Micah Gersten <micahg@ubuntu.com>
Description: Fix build failure with --as-needed (Closes: #654838).
diff -Naurp syslinux.orig/utils/Makefile syslinux/utils/Makefile
--- syslinux.orig/utils/Makefile 2011-12-23 14:53:26.653571511 +0100
+++ syslinux/utils/Makefile 2012-01-22 18:55:03.849466924 +0100
@@ -51,7 +51,7 @@ isohdpfx.c: $(ISOHDPFX) isohdpfxarray.pl
$(PERL) isohdpfxarray.pl $(ISOHDPFX) > $@
isohybrid: isohybrid.o isohdpfx.o
- $(CC) $(LDFLAGS) -luuid -o $@ $^
+ $(CC) $(LDFLAGS) -o $@ $^ -luuid
gethostip: gethostip.o
$(CC) $(LDFLAGS) -o $@ $^