buildrootschalter/package/mxml/mxml-fix-cross-target-insta...

56 lines
2.0 KiB
Diff

From: Baruch Siach <baruch@tkos.co.il>
Subject: [PATCH] mxml: workaround for cross build
The added patch is a workaround for cross build as follows:
* disable run of a test binary at build time
* disable generation of documentation using the mxmldoc binary
* remove now non-existent entries from the install target
* disable strip when running install
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
---
diff -Nuar mxml-2.7-orig/Makefile.in mxml-2.7/Makefile.in
--- mxml-2.7-orig/Makefile.in 2011-04-13 18:43:32.000000000 +0300
+++ mxml-2.7/Makefile.in 2012-05-16 07:21:42.677220980 +0300
@@ -57,7 +57,7 @@
# Install commands...
#
-INSTALL_BIN = $(LIBTOOL) $(INSTALL) -m 755 -s
+INSTALL_BIN = $(LIBTOOL) $(INSTALL) -m 755
INSTALL_DATA = $(INSTALL) -m 644
INSTALL_DIR = $(INSTALL) -d
INSTALL_LIB = $(LIBTOOL) $(INSTALL) -m 755
@@ -88,7 +88,7 @@
mxml-index.o mxml-node.o mxml-search.o mxml-set.o
LIBOBJS = $(PUBLIBOBJS) mxml-private.o mxml-string.o
OBJS = mxmldoc.o testmxml.o $(LIBOBJS)
-TARGETS = $(LIBMXML) mxmldoc testmxml mxml.xml doc/mxml.man
+TARGETS = $(LIBMXML) libmxml.a
#
@@ -140,9 +140,6 @@
#
install: $(TARGETS) install-$(LIBMXML) install-libmxml.a
- echo Installing mxmldoc in $(BUILDROOT)$(bindir)...
- $(INSTALL_DIR) $(BUILDROOT)$(bindir)
- $(INSTALL_BIN) mxmldoc $(BUILDROOT)$(bindir)
echo Installing documentation in $(BUILDROOT)$(docdir)...
$(INSTALL_DIR) $(BUILDROOT)$(docdir)
for file in $(DOCFILES); do \
@@ -154,11 +151,6 @@
echo Installing pkgconfig files in $(BUILDROOT)$(libdir)/pkgconfig...
$(INSTALL_DIR) $(BUILDROOT)$(libdir)/pkgconfig
$(INSTALL_DATA) mxml.pc $(BUILDROOT)$(libdir)/pkgconfig
- echo Installing man pages in $(BUILDROOT)$(mandir)...
- $(INSTALL_DIR) $(BUILDROOT)$(mandir)/man1
- $(INSTALL_MAN) doc/mxmldoc.man $(BUILDROOT)$(mandir)/man1/mxmldoc.1
- $(INSTALL_DIR) $(BUILDROOT)$(mandir)/man3
- $(INSTALL_MAN) doc/mxml.man $(BUILDROOT)$(mandir)/man3/mxml.3
install-libmxml.a:
echo Installing libmxml.a to $(BUILDROOT)$(libdir)...