buildrootschalter/package/dmidecode/dmidecode-build-system-fixe...

36 lines
969 B
Diff

Minor build system fixes
Usual build system fixes to allow CC/CFLAGS/LDFLAGS to be overriden
from the command line, and completed by additional flags from the
Makefile.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/Makefile
===================================================================
--- a/Makefile
+++ b/Makefile
@@ -12,9 +12,10 @@
# (at your option) any later version.
#
-CC = gcc
-CFLAGS = -W -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual \
- -Wcast-align -Wwrite-strings -Wmissing-prototypes -Winline -Wundef
+CC ?= gcc
+override CFLAGS += \
+ -W -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual \
+ -Wcast-align -Wwrite-strings -Wmissing-prototypes -Winline -Wundef
#CFLAGS += -DBIGENDIAN
#CFLAGS += -DALIGNMENT_WORKAROUND
@@ -23,7 +24,7 @@
#CFLAGS += -g
# Pass linker flags here
-LDFLAGS =
+override LDFLAGS +=
DESTDIR =
prefix = /usr/local