buildrootschalter/package/util-linux/util-linux-003-program-invocation-short-name.patch
Ryan Barnett 0064439712 util-linux: fix build failure with older systems
Adding patch util-linux-002-support-older-machines.patch to fix issues
when building for older systems.

Making all util-linux patches apply cleanly (fuzz fixes)

Fixes http://autobuild.buildroot.org/results/349/349d6ff938b093623618669a1acb390aa2a5fafe
Fixes http://autobuild.buildroot.org/results/57e/57e2c612c46b9e3b5f7bb213fcb3825b23fb7fc7

Signed-off-by: Ryan Barnett <rjbarnet@rockwellcollins.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
2013-09-09 11:41:33 +02:00

12 lines
340 B
Diff

--- a/configure.ac 2013-09-05 15:31:21.590981268 -0500
+++ b/configure.ac 2013-09-05 15:31:29.160981049 -0500
@@ -387,7 +387,7 @@
AC_MSG_CHECKING([whether program_invocation_short_name is defined])
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
- #include <argp.h>
+ #include <errno.h>
]], [[
program_invocation_short_name = "test";
]])], [