buildrootschalter/package/setserial/setserial-2.17-build-system-fix.patch
Thomas Petazzoni aaa2b660a9 setserial: convert to autotargets and fix manpages install
Close #2269

[Peter: fix Makefile patch to not strip wrong file, rename hayes patch]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
2010-07-27 00:48:27 +02:00

29 lines
1.0 KiB
Diff

Install the setserial program in /usr/bin instead of /bin, and make
sure that the directories (especially the manpages directory) are
created before installing files to them. This is similar to what
automake does.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
Makefile.in | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)
Index: setserial-2.17/Makefile.in
===================================================================
--- setserial-2.17.orig/Makefile.in
+++ setserial-2.17/Makefile.in
@@ -26,9 +26,10 @@ setserial.cat: setserial.8
nroff -man setserial.8 > setserial.cat
install: setserial setserial.8
- $(INSTALL_PROGRAM) setserial $(DESTDIR)/bin
- $(STRIP) $(DESTDIR)/bin/setserial
- $(INSTALL_DATA) setserial.8 $(DESTDIR)/usr/man/man8
+ mkdir -p $(DESTDIR)/usr/bin
+ $(INSTALL_PROGRAM) setserial $(DESTDIR)/usr/bin
+ mkdir -p $(DESTDIR)/usr/share/man/man8
+ $(INSTALL_DATA) setserial.8 $(DESTDIR)/usr/share/man/man8
clean:
$(RM) setserial setserial.o setserial.cat *~