buildrootschalter/sources/openssh.patch

212 lines
4.7 KiB
Diff

--- openssh-3.6.1p1/Makefile.in.orig 2003-03-20 17:34:34.000000000 -0700
+++ openssh-3.6.1p1/Makefile.in 2003-04-25 17:09:00.000000000 -0600
@@ -27,7 +27,7 @@
RAND_HELPER=$(libexecdir)/ssh-rand-helper
PRIVSEP_PATH=@PRIVSEP_PATH@
SSH_PRIVSEP_USER=@SSH_PRIVSEP_USER@
-STRIP_OPT=@STRIP_OPT@
+STRIP_OPT=
PATHS= -DSSHDIR=\"$(sysconfdir)\" \
-D_PATH_SSH_PROGRAM=\"$(SSH_PROGRAM)\" \
--- openssh-3.5p1.orig/configure.ac Thu Sep 26 02:38:47 2002
+++ openssh-3.5p1/configure.ac Mon Mar 17 14:55:00 2003
@@ -504,6 +504,9 @@
[
AC_MSG_RESULT(no)
AC_DEFINE(BROKEN_ONE_BYTE_DIRENT_D_NAME)
+ ],
+ [AC_MSG_RESULT(yes)
+ AC_MSG_WARN([Cannot run test when crosscompiling, defaulted to yes.])
]
)
@@ -535,6 +538,9 @@
[
AC_MSG_RESULT(no)
AC_MSG_ERROR([** Incomplete or missing s/key libraries.])
+ ],
+ [AC_MSG_RESULT(yes)
+ AC_MSG_WARN([Cannot run test when crosscompiling, defaulted to yes.])
])
fi
]
@@ -676,6 +682,9 @@
AC_MSG_RESULT(no)
AC_DEFINE(BROKEN_SNPRINTF)
AC_MSG_WARN([****** Your snprintf() function is broken, complain to your vendor])
+ ],
+ [AC_MSG_RESULT(yes)
+ AC_MSG_WARN([Cannot run test when crosscompiling, defaulted to yes.])
]
)
fi
@@ -810,6 +819,10 @@
[
AC_MSG_RESULT(not found)
AC_MSG_ERROR(OpenSSL version header not found.)
+ ],
+ [
+ ssl_header_ver="90700f (OpenSSL 0.9.7a 19 Feb 2003)"
+ AC_MSG_WARN([Cannot run test when crosscompiling, defaulted to $ssl_header_ver])
]
)
@@ -843,6 +856,10 @@
[
AC_MSG_RESULT(not found)
AC_MSG_ERROR(OpenSSL library not found.)
+ ],
+ [
+ ssl_library_ver="90700f (OpenSSL 0.9.7a 19 Feb 2003)"
+ AC_MSG_WARN([Cannot run test when crosscompiling, defaulted to $ssl_library_ver])
]
)
@@ -860,6 +877,10 @@
[
AC_MSG_RESULT(no)
AC_MSG_ERROR(Your OpenSSL headers do not match your library)
+ ],
+ [
+ AC_MSG_RESULT(yes)
+ AC_MSG_WARN([Cannot run test when crosscompiling, defaulted to yes.])
]
)
@@ -889,6 +910,11 @@
# Default to use of the rand helper if OpenSSL doesn't
# seed itself
USE_RAND_HELPER=yes
+ ],
+ [
+ OPENSSL_SEEDS_ITSELF=yes
+ AC_MSG_RESULT(yes)
+ AC_MSG_WARN([Cannot run test when crosscompiling, defaulted to yes.])
]
)
@@ -1475,7 +1501,8 @@
#else
main() { exit(0); }
#endif
- ], [ true ], [ AC_DEFINE(BROKEN_SNPRINTF) ]
+ ], [ true ], [ AC_DEFINE(BROKEN_SNPRINTF) ],
+ [ true ]
)
fi
AC_SUBST(NO_SFTP)
@@ -1596,6 +1623,7 @@
}
],
[ ac_cv_have_accrights_in_msghdr="yes" ],
+ [ ac_cv_have_accrights_in_msghdr="no" ],
[ ac_cv_have_accrights_in_msghdr="no" ]
)
])
@@ -1620,7 +1648,8 @@
}
],
[ ac_cv_have_control_in_msghdr="yes" ],
- [ ac_cv_have_control_in_msghdr="no" ]
+ [ ac_cv_have_control_in_msghdr="no" ],
+ [ ac_cv_have_control_in_msghdr="yes" ]
)
])
if test "x$ac_cv_have_control_in_msghdr" = "xyes" ; then
@@ -1931,13 +1960,14 @@
)
fi
fi
+if test "$cross_compiling" != yes; then
AC_CHECK_FILE("/dev/ptc",
[
AC_DEFINE_UNQUOTED(HAVE_DEV_PTS_AND_PTC)
have_dev_ptc=1
]
)
-
+fi
# Options from here on. Some of these are preset by platform above
AC_ARG_WITH(mantype,
[ --with-mantype=man|cat|doc Set man page type],
--- openssh-3.5p1.orig/sshd_config Fri Sep 27 05:21:58 2002
+++ openssh-3.5p1/sshd_config Mon Mar 17 14:55:00 2003
@@ -89,5 +89,8 @@
#Banner /some/path
#VerifyReverseMapping no
+ClientAliveInterval 15
+ClientAliveCountMax 4
+
# override default of no subsystems
-Subsystem sftp /usr/libexec/sftp-server
+Subsystem sftp /usr/sbin/sftp-server
--- openssh-3.6.1p1/S50sshd Fri Sep 27 05:21:58 2002
+++ openssh-3.6.1p1/S50sshd Mon Mar 17 14:55:00 2003
@@ -0,0 +1,64 @@
+#!/bin/sh
+#
+# sshd Starts sshd.
+#
+
+# Make sure the ssh-keygen progam exists
+[ -f /usr/bin/ssh-keygen ] || exit 0
+
+# Check for the SSH1 RSA key
+if [ ! -f /etc/ssh_host_key ] ; then
+ echo Generating RSA Key...
+ /usr/bin/ssh-keygen -t rsa1 -f /etc/ssh_host_key -C '' -N ''
+fi
+
+# Check for the SSH2 RSA key
+if [ ! -f /etc/ssh_host_rsa_key ] ; then
+ echo Generating RSA Key...
+ /usr/bin/ssh-keygen -t rsa -f /etc/ssh_host_rsa_key -C '' -N ''
+fi
+
+# Check for the SSH2 DSA key
+if [ ! -f /etc/ssh_host_dsa_key ] ; then
+ echo Generating DSA Key...
+ echo THIS CAN TAKE A MINUTE OR TWO DEPENDING ON YOUR PROCESSOR!
+ echo
+ /usr/bin/ssh-keygen -t dsa -f /etc/ssh_host_dsa_key -C '' -N ''
+fi
+
+umask 077
+
+start() {
+ echo -n "Starting sshd: "
+ /usr/sbin/sshd
+ touch /var/lock/sshd
+ echo "OK"
+}
+stop() {
+ echo -n "Stopping sshd: "
+ killall sshd
+ rm -f /var/lock/sshd
+ echo "OK"
+}
+restart() {
+ stop
+ start
+}
+
+case "$1" in
+ start)
+ start
+ ;;
+ stop)
+ stop
+ ;;
+ restart|reload)
+ restart
+ ;;
+ *)
+ echo $"Usage: $0 {start|stop|restart}"
+ exit 1
+esac
+
+exit $?
+