buildrootschalter/sources/binutils-uclibc-200-build_modules.patch
Manuel Novoa III 9168e83809 Enable building <arch>-linux-uclibc toolchains. Note that, due to config
issues for applications, we also create staging_dir/bin/<arch>-linux-*
symlinks which allows us to configure most apps with target=<arch>-linux.

gcc 3.3.2 libstdc++ now correctly identifies uclibc locale support.
There are still some issues (mainly related to wide char time strings
and wcsftime) to be addressed, but those are on hold until the uClibc
locale internals are reworked once again.

With the new stuff, we can also build gcc 2.95 and STLport again, although
the native gcc build for the target is failing.

Archs supported (some archs not yet tested):
 2.95 - i386, arm, mips*, powerpc.
 3.3.2 - Hopefull all for which uClibc has shared lib support.
2004-01-14 10:03:44 +00:00

32 lines
939 B
Diff

Get around an odd build failure.
diff -urN binutils-2.14.90.0.6/configure binutils-2.14.90.0.6-uClibc/configure
--- binutils-2.14.90.0.6/configure 2003-08-21 10:29:32.000000000 -0500
+++ binutils-2.14.90.0.6-uClibc/configure 2004-01-07 05:43:40.000000000 -0600
@@ -906,6 +906,11 @@
fi
+case "$target" in
+ *-*-*-uclibc*)
+ build_modules=
+ ;;
+esac
################################################################################
srcname="gnu development package"
diff -urN binutils-2.14.90.0.6/configure.in binutils-2.14.90.0.6-uClibc/configure.in
--- binutils-2.14.90.0.6/configure.in 2003-08-21 10:29:30.000000000 -0500
+++ binutils-2.14.90.0.6-uClibc/configure.in 2004-01-07 05:44:02.000000000 -0600
@@ -178,6 +178,11 @@
fi
+case "$target" in
+ *-*-*-uclibc*)
+ build_modules=
+ ;;
+esac
################################################################################
srcname="gnu development package"