buildrootschalter/package/x11r7/xapp_xgc/xapp_xgc-replace-ac-check-file.patch
Thomas Petazzoni b6d2046c1e xapp_xgc: fix build against Xmu by bumping version
Fix a build issue similar to the one encountered on xapp_listres at
http://autobuild.buildroot.org/results/06d0ef38165769df38047c1f64d4cfae835e9e54/.

Note that this new version requires a minor cross-compilation fix in
configure.ac, which has already been committed upstream but is not yet
part of a release tarball.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
2012-11-04 11:22:55 +01:00

30 lines
917 B
Diff

From ff668395fc408f540604bd534e323b483f52a4ea Mon Sep 17 00:00:00 2001
From: Gaetan Nadon <memsize@videotron.ca>
Date: Mon, 01 Nov 2010 17:19:23 +0000
Subject: config: replace AC_CHECK_FILE with test -f
* AC_CHECK_FILE doesn't work for cross compilation
Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
---
diff --git a/configure.ac b/configure.ac
index 667a3e7..0644050 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,8 +36,11 @@ XORG_DEFAULT_OPTIONS
AC_PROG_LEX
AC_PROG_YACC
AC_PATH_PROG([YACC_INST], $YACC)
-AC_CHECK_FILE([$srcdir/gram.c], [],
- [test -z "$YACC_INST" && AC_MSG_ERROR([yacc not found - unable to compile gram.y])])
+if test ! -f "gram.c"; then
+ if test -z "$YACC_INST"; then
+ AC_MSG_ERROR([yacc not found - unable to compile gram.y])
+ fi
+fi
PKG_CHECK_MODULES(XGC, xaw7 xt)
xt_appdefaultdir=`$PKG_CONFIG --variable=appdefaultdir xt`
--
cgit v0.9.0.2-2-gbebe