buildrootschalter/package/orbit/orbit-01-fix-installation.patch
Assaf Inbal 02e4326fe7 orbit: New package
An MVC web framework for Lua

[Thomas P: add patch to fix installation procedure, and use the
provided Makefile for installation. Remove build-time dependency on
wsapi since there's nothing to build in 'orbit'. Remove run-time
dependency on 'rings', since it's not clear why Orbit would depend on
that.]

Signed-off-by: Assaf Inbal <shmuelzon@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2013-08-13 11:05:08 +02:00

27 lines
757 B
Diff

Fix installation commands
The installation commands did not match the location of the source
files within the Orbit source tree.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/Makefile
===================================================================
--- a/Makefile
+++ b/Makefile
@@ -11,12 +11,9 @@
mkdir -p $(LUA_DIR)
cp src/orbit.lua $(LUA_DIR)
mkdir -p $(LUA_DIR)/orbit
- cp src/model.lua $(LUA_DIR)/orbit
- cp src/cache.lua $(LUA_DIR)/orbit
- cp src/pages.lua $(LUA_DIR)/orbit
- cp src/ophandler.lua $(LUA_DIR)/orbit
+ cp src/orbit/*.lua $(LUA_DIR)/orbit
mkdir -p $(BIN_DIR)
- cp src/orbit $(BIN_DIR)
+ cp src/launchers/* $(BIN_DIR)
if [ -f ./wsapi/Makefile ]; then \
cd wsapi && make install; \
fi