buildrootschalter/package/usb_modeswitch_data/usb_modeswitch_data-makefile.patch
J.C. Woltz 572ba0692c new package: usb_modeswitch_data
usb_modeswitch_data provides udev rules for usb VID/PID combinations to
switch usb deices from their default mode into a more useable mode. The
default mode usually is a cdrom with installation software that is of
little use in an embedded linux situation

Signed-off-by: J.C. Woltz <jwoltz@gmail.com>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2012-08-12 19:23:37 +02:00

28 lines
801 B
Diff

Fixed Makefile install sections to not reload udev rules. In a
cross-compiler environment, it is not wanted to reload the host udev rules.
Signed-off-by: J.C. Woltz <jwoltz@gmail.com>
--- usb_modeswitch_data-20120120.orig/Makefile 2012-01-20 17:25:32.000000000 -0500
+++ usb_modeswitch_data-20120120/Makefile 2012-02-06 14:20:47.000000000 -0500
@@ -12,9 +12,9 @@
clean:
-install: files-install db-install rules-reload
+install: files-install db-install
-install-packed: files-install db-install-packed rules-reload
+install-packed: files-install db-install-packed
files-install:
install -d $(PREFIX)/share/usb_modeswitch
@@ -50,7 +50,7 @@
fi \
fi
-uninstall: files-uninstall rules-reload
+uninstall: files-uninstall
files-uninstall:
$(RM) $(RULESDIR)/40-usb_modeswitch.rules