buildrootschalter/package/libroxml/libroxml-0001-werror.patch
Simon Dawson 2b2c657957 libroxml: fix avr32 build failure
The -Wno-unused-result option is not understood by the version of gcc used by the
avr32 toolchain. Remove the option from the compilation flags.

Fixes build failures such as the following.

  http://autobuild.buildroot.net/results/e22/e22d94fca3eabb4e54d82af04319f17ad8e10c20/

The single existing patch for libroxml has been renamed to include a numerical
component for application order sorting. The existing patch has also been updated
to apply without fuzz.

Signed-off-by: Simon Dawson <spdawson@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2013-11-22 12:19:57 +01:00

23 lines
678 B
Diff

[PATCH] remove -Werror from CFLAGS
-Werror should only be used during development, not in released SW.
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
---
Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Index: a/Makefile
===================================================================
--- a/Makefile
+++ b/Makefile
@@ -46,7 +46,7 @@
# options
override CPPFLAGS += -Iinc/
-override CFLAGS += $(OPTIM) -fPIC -Wall -Wextra -Wno-unused-parameter -Wno-unused-result -Werror -Iinc/ $(DEFINES)
+override CFLAGS += $(OPTIM) -fPIC -Wall -Wextra -Wno-unused-parameter -Wno-unused-result -Iinc/ $(DEFINES)
override LDFLAGS +=
ifeq ("$(OS)", "Darwin")