buildrootschalter/package/libhid/libhid-0001-dont-fiddle-with-debug-flags.patch
Bernd Kuhls 2875ec9124 package/libhid: Fix build with BR2_ENABLE_DEBUG=yes
Updated Thomas´ patch fix also fix the case when debug is enabled, otherwise this error occurs:

/bin/bash ../libtool  --tag=CC   --mode=compile /home/fli4l/br5/output/host/usr/bin/i586-buildroot-linux-uclibc-gcc
 -DHAVE_CONFIG_H -I. -I..   -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -fPIC
 -I/home/fli4l/br5/output/host/usr/i586-buildroot-linux-uclibc/sysroot/usr/include -D_LARGEFILE_SOURCE
 -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -pipe s -g2 -O0 -g -Wall -W -c -o hidparser.lo hidparser.c
libtool: compile:  /home/fli4l/br5/output/host/usr/bin/i586-buildroot-linux-uclibc-gcc -DHAVE_CONFIG_H -I.
 -I.. -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -fPIC
 -I/home/fli4l/br5/output/host/usr/i586-buildroot-linux-uclibc/sysroot/usr/include
 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -pipe s -g2 -O0
 -g -Wall -W -c hidparser.c  -fPIC -DPIC -o .libs/hidparser.o

i586-buildroot-linux-uclibc-gcc: error: s: No such file or directory

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2014-10-26 22:08:06 +01:00

20 lines
708 B
Diff

MD_CONF_DEBUGGING changes CFLAGS and CXXFLAGS with a horrible magic so disable
it to prevent compilation errors.
downloaded from
http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/dev-libs/libhid/files/libhid-0.2.16-gentoo.patch?revision=1.1&view=markup
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
diff -uNr libhid-0.2.16.org/configure.ac libhid-0.2.16/configure.ac
--- libhid-0.2.16.org/configure.ac 2007-04-01 22:32:10.000000000 +0200
+++ libhid-0.2.16/configure.ac 2014-10-19 21:31:00.550091947 +0200
@@ -78,7 +78,6 @@
AC_C_BIGENDIAN
AC_C_STRINGIZE
-MD_CONF_DEBUGGING
MD_CONF_COMPILER
AM_CONDITIONAL(OS_LINUX, test "$MD_OS" = "linux")
AM_CONDITIONAL(OS_BSD, test "$MD_OS" = "bsd")