buildrootschalter/package/libmicrohttpd/libmicrohttpd-01-openssl-conditional.patch
Gustavo Zacarias 37dfcbabb9 libmicrohttpd: disable spdy support
It requires OpenSSL and IPv6 support and it should probably be an
option since SSL support uses GnuTLS thus making a huge target
footprint with 2 SSL/TLS libraries for full support.
But most of all it's considered experimental.
Fixes:
http://autobuild.buildroot.net/results/836/836c39c11cecbcf9399675ba3ab01202417b9642/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
2013-09-02 12:43:59 +02:00

21 lines
764 B
Diff

Subject: [PATCH] Fix configure failure for --disable-spdy
The @HAVE_OPENSSL@ conditional is used in src/Makefile.in so when SPDY
support is forcibly disabled the AM_CONDITIONAL is never executed, causing
configure to bail out.
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
diff -Nura libmicrohttpd-0.9.29.orig/configure.ac libmicrohttpd-0.9.29/configure.ac
--- libmicrohttpd-0.9.29.orig/configure.ac 2013-09-02 06:17:44.660620584 -0300
+++ libmicrohttpd-0.9.29/configure.ac 2013-09-02 06:36:44.598189751 -0300
@@ -341,6 +341,8 @@
enable_spdy="yes"],
[AM_CONDITIONAL(HAVE_OPENSSL, false)
enable_spdy="no"])
+else
+ AM_CONDITIONAL(HAVE_OPENSSL, false)
fi
if test "$enable_spdy" = "yes"