buildrootschalter/package/keyutils/keyutils-02-fix-install-rule.patch
Vicente Olivert Riera 339df19f7a keyutils: Bump version to 1.5.9, fix patches and
- Bump version to 1.5.9
- Remove patches already included in this version
- Use make parameters instead of environment variables
- Add an upstream patch to fix building statically
- Adapt old patches to the new version
- Add a hash file

Fixes:
  http://autobuild.buildroot.net/results/ced/ced596bd1c73286f7044f5a8e11b6588fc973f11/

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2014-09-28 22:30:05 +02:00

21 lines
778 B
Diff

Makefile: fix install rule
Do not link the .so with an absolute path, otherwise it may point to
the host library.
Based on the former patch by Yann E. MORIN.
Signed-off-by: Vicente Olivert Riera <vincent.riera@imgtec.com>
--- keyutils-1.5.9/Makefile.orig 2014-09-22 16:13:41.593562765 +0100
+++ keyutils-1.5.9/Makefile 2014-09-22 16:14:05.377963952 +0100
@@ -168,7 +168,7 @@ ifeq ($(NO_SOLIB),0)
$(INSTALL) -D $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(LIBNAME)
$(LNS) $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(SONAME)
mkdir -p $(DESTDIR)$(USRLIBDIR)
- $(LNS) $(LIBDIR)/$(SONAME) $(DESTDIR)$(USRLIBDIR)/$(DEVELLIB)
+ $(LNS) $(SONAME) $(DESTDIR)$(USRLIBDIR)/$(DEVELLIB)
endif
$(INSTALL) -D keyctl $(DESTDIR)$(BINDIR)/keyctl
$(INSTALL) -D request-key $(DESTDIR)$(SBINDIR)/request-key