buildrootschalter/package/ympd/ympd-0001-CMake-cross-compile-mkdata.patch
Eric Limpens 40aa523af2 ympd: new package
[Thomas:
 - Add the package to package/Config.in
 - Add dependency on largefile
 - Add new patch to CMakeLists.txt to remove the unused C++ dependency
 - Change the existing CMakeLists.txt patch to simply remove the
   problematic code, and reword the explanation.]

Signed-off-by: Eric Limpens <limpens@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2014-10-04 14:39:03 +02:00

25 lines
761 B
Diff

Do not build the mkdata tool
The mkdata tool is needed on the host, during the build, so building
it for the target does not work when cross-compiling. Buildroot will
manually build mkdata before starting the ympd build.
Upstream is looking into a proper solution.
Signed-off-by: Eric Limpens <Limpens@Gmail.com>
Index: b/CMakeLists.txt
===================================================================
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,9 +28,6 @@
htdocs/index.html
)
-add_executable(mkdata htdocs/mkdata.c)
-get_target_property(MKDATA_EXE mkdata LOCATION)
-
add_custom_command(OUTPUT ${PROJECT_BINARY_DIR}/assets.c
COMMAND ${MKDATA_EXE} ${RESOURCES} > ${PROJECT_BINARY_DIR}/assets.c
WORKING_DIRECTORY ${PROJECT_SOURCE_DIR}