buildrootschalter/package/libevent/0001-Disable-building-test-programs.patch
Maxime Hadjinlian cfb4d2451b libevent: Use github call & fix patch
We want to use the github helper since there is not a specific releases
tarball that we can download, as specified in the manual.

This tarball is generated from the tag, which doesn't contains the
autotools generated files, we then need to use AUTORECONF.

We want to use the github helper anyway as the current URL use an old
GitHub feature which was called 'Download' where you could upload files
along your repositories, theses files were not related to your tags.

This features has been replaced with the 'Release' option where you can
create a release from a git tag. But these tarball are generated from
the sources and they don't contains all the generated autotools file.

Since the old URL scheme can be deprecated at any time, we want to
switch to the new URL scheme, which in the case of libevent, implies
    having to do an AUTORECONF.

The patch that was already present is updated to apply against
Makefile.am instead of Makefile.in

The second patch is backported from upstream to remove the use of
$(top_src_dirs) which makes current autotools error out.

Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2014-10-26 16:57:27 +01:00

31 lines
756 B
Diff

From 4b5a135fa681e85eb6988a379f59f3c7a41cc48c Mon Sep 17 00:00:00 2001
From: Gilles Talis <gilles.talis@gmail.com>
Date: Fri, 21 Jun 2013 15:25:11 -0700
Subject: [PATCH 1/2] Disable building test programs
We are not really interested in building test programs.
Moreover, these programs use fork() function that is
not available on MMU-less architectures.
Signed-off-by: Gilles Talis <gilles.talis@gmail.com>
---
Makefile.am | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile.am b/Makefile.am
index 42879a3..dc90359 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -126,7 +126,7 @@ else
noinst_LTLIBRARIES = $(LIBEVENT_LIBS_LA)
endif
-SUBDIRS = . include sample test
+SUBDIRS = . include sample
if BUILD_WIN32
--
2.1.1