buildrootschalter/package/crda/crda-0001-Makefile-allow-to-override-python-interpreter.patch
Samuel Martin 23dfff36f0 crda: override python interperter
During its build, crda calls a python script importing m2crypto module
which requires python2 interpreter.

So, we have a build dependency against host-python.

Also, we make sure this python script is interpreted using the right
python interpreter; we add a patch allowing to enforce this and
explicitly set it.

Fixes:
  http://autobuild.buildroot.net/results/a1e/a1e53d66d3962fd5431e7601937b071a0a3c2084/

[Thomas: fix typos in comments, some of them noticed by Yann.]

Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Cc: Gustavo Zacarias <gustavo@zacarias.com.ar>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2014-04-05 16:43:17 +02:00

35 lines
936 B
Diff

From 6831024a247fd89c7f7adcbee8a0be991b3caaf4 Mon Sep 17 00:00:00 2001
From: Samuel Martin <s.martin49@gmail.com>
Date: Sun, 2 Mar 2014 23:45:44 +0100
Subject: [PATCH] Makefile: allow to override python interpreter
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
---
Makefile | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 1d34bde..d7134ff 100644
--- a/Makefile
+++ b/Makefile
@@ -42,6 +42,7 @@ LDLIBS += -lgcrypt
reglib.o: keys-gcrypt.c
endif
+PYTHON ?= python2
MKDIR ?= mkdir -p
INSTALL ?= install
@@ -103,7 +104,7 @@ $(REG_BIN):
keys-%.c: utils/key2pub.py $(wildcard $(PUBKEY_DIR)/*.pem)
$(NQ) ' GEN ' $@
$(NQ) ' Trusted pubkeys:' $(wildcard $(PUBKEY_DIR)/*.pem)
- $(Q)./utils/key2pub.py --$* $(wildcard $(PUBKEY_DIR)/*.pem) $@
+ $(Q)$(PYTHON) ./utils/key2pub.py --$* $(wildcard $(PUBKEY_DIR)/*.pem) $@
%.o: %.c regdb.h reglib.h
$(NQ) ' CC ' $@
--
1.9.0