buildrootschalter/package/ti-gfx/ti-gfx-km_install_modules.patch
Spenser Gilliland 7fdcf8e897 ti-gfx: add new package
adds accelerated GPU support for the OMAP35xx, AM35xx, AM37xx, DM37xx,
AM387x, DM814x, AM389x, DM816x, and AM335x platforms.

[Peter: fix .pc files install]
Signed-off-by: Spenser Gilliland <spenser@gillilanding.com>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: Sundareson, Prabindh <prabu@ti.com>
Cc: Peter Korsgaard <jacmet@uclibc.org>
Cc: Sinan Akpolat <sinan@linkas.com.tr>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
2013-07-16 00:28:15 +02:00

20 lines
665 B
Diff

Patch to add modules_install target to the modules makefile. This makes
installation a little easier.
Signed-off-by: Spenser Gilliland <spenser@gillilanding.com>
----
Index: ti-gfx-4_09_00_01/GFX_Linux_KM/Makefile
===================================================================
--- ti-gfx-4_09_00_01.orig/GFX_Linux_KM/Makefile 2013-03-07 11:00:11.000000000 -0600
+++ ti-gfx-4_09_00_01/GFX_Linux_KM/Makefile 2013-05-23 01:36:29.356676281 -0500
@@ -479,6 +479,9 @@
all:
$(MAKE) -C $(KERNELDIR) M=`pwd` $*
+install:
+ $(MAKE) -C $(KERNELDIR) M=`pwd` modules_install
+
clean:
@find . -name "*.o" -exec rm -r {} \;
@find . -name "*.ko" -exec rm -r {} \;