buildrootschalter/package/gettext/gettext-03-option-to-disable-tools.patch
Thomas Petazzoni 0d4133edfe gettext: don't patch different the host and target build
Until now, the gettext source code was being patched differently for
the host and the target build, which is going to be incompatible with
out-of-tree build. The difference is that the gettext tools could be
disabled in the target build, but are always enabled on the host
build.

Therefore, this commit switches the gettext package to using proper
patches against the relevant configure.ac and Makefile.am
files. gettext is now being autoreconfigured. Configuration options
are also passed for the host variant, in order to disable the build of
a large number of things we don't care about.

Finally, the two existing patches are renamed to include a number in
their filename.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
2013-05-30 21:45:03 +02:00

43 lines
1.2 KiB
Diff

Add a --disable-tools option
This patch adds a --disable-tools option that allows to disable the
compilation of the gettext tools, which may not be necessary on a
small embedded Linux system.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/configure.ac
===================================================================
--- a/configure.ac
+++ b/configure.ac
@@ -37,6 +37,10 @@
dnl Checks for library functions.
+AC_ARG_ENABLE([tools], [--disable-tools do not build tools],
+ [enable_tools=$enableval], [enable_tools=yes])
+AM_CONDITIONAL([ENABLE_TOOLS], [test "$enable_tools" = "yes"])
+
AC_CONFIG_SUBDIRS([gettext-runtime gettext-tools])
dnl Ensure that "configure --help" lists all the command line options that
Index: b/Makefile.am
===================================================================
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,7 +20,13 @@
ACLOCAL = build-aux/fixaclocal @ACLOCAL@
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = gnulib-local gettext-runtime gettext-tools
+if ENABLE_TOOLS
+TOOLS_SUBDIR = gettext-tools
+else
+TOOLS_SUBDIR =
+endif
+
+SUBDIRS = gnulib-local gettext-runtime $(TOOLS_SUBDIR)
EXTRA_DIST = \
version.sh DEPENDENCIES PACKAGING HACKING ChangeLog.0 autogen.sh \