buildrootschalter/toolchain/gcc/4.0.4/402-libbackend_dep_gcov-iov.h.patch
Bernhard Reutner-Fischer 99cf7293f9 - add cc-option and use it to check for stuff that is benefical for PREFER_IMA
- backport the libbackend.o gcov-iov.h dependency fixup from 4.2 to 4.0
2007-02-12 13:38:06 +00:00

12 lines
543 B
Diff

--- gcc-4.0.4.orig/gcc/Makefile.in 2007-02-12 11:35:43.000000000 +0100
+++ gcc-4.0.4/gcc/Makefile.in 2007-02-12 11:38:04.000000000 +0100
@@ -2202,7 +2202,7 @@ mips-tdump.o : mips-tdump.c $(CONFIG_H)
# FIXME: writing proper dependencies for this is a *LOT* of work.
libbackend.o : $(OBJS-common:.o=.c) $(out_file) \
insn-config.h insn-flags.h insn-codes.h insn-constants.h \
- insn-attr.h
+ insn-attr.h gcov-iov.h
$(CC) $(ALL_CFLAGS) $(ALL_CPPFLAGS) \
-DTARGET_NAME=\"$(target_noncanonical)\" \
-DLOCALEDIR=\"$(localedir)\" \